Audio Glitches Issue

Some users might experience Audio skipping or glitches throughout playback.

Usually this means that Vox is not given enough audio file data when it needs it. There are several things You can check to avoid this:

1) Maximise playback buffer size

  • Please goto Vox Preferences, Audio, advanced tab and find "Buffer" slider at the bottom of window. Increase the buffer size to maximum (5000ms). To check playback You have to start the same track again by double - clicking on it in Vox for the new buffer setting to take effect.

2) Move file to mac HD

  • Make sure the file played is located on the media fast enough for Vox to have access. For example, if the file located on external hard drive or at a network location - try moving it to Your mac's local hard drive so that Vox has faster access to it. If that stops glitching, then the problem might be in the slow media connection. This problem can partially be solved by increasing buffer size to maximum, as said in step 1).

4) Airplay or Sonos glitches

  • If You experience glitches when playing to Airplay output, that usually means Your wifi network if olerloaded or the area You are in is too lboated with many wifi networks conflicting with each other. Wifi netwirk tune-up and optimization is required in that case.

3) Check Your output device

  • Glitches sometimes could be attributed to problems with external/network soundcards and outboard. If You hear glitches on such devices, Go to Vox Preferencres -> Audio and in the field "output" select built-in "Internal Speakers" or "headphones".

If Your file plays ok through built-in device, then the problem is in external device drivers or connection. Write to us about such case, including the model of external output device, Vox version, OS version.


If all above does not help, please check the following:

1) Are some Audio Units on? Some AU's may cause glitches and distortion without letting You know. Check this by hitting Cmd+Option+4 in Vox window. The Audio Unit chain window will appear. If there are active units in the list, delete all Audio Units by selecting by one and hitting "delete" or minus so that "Chain is Empty" notion appears. Launch file again and check if it glitches now.

2) Try "load the whole file into memory" mode. Vox-Preferences->Audio->Advanced, enable "Try to load the whole file into memory". This does work on a majority of files, except really large ones. Launch file again and check if it glitches now.

3) is Sync sample rate option on? it may work less than perfoct on some external audio devices. Disable it and check the playback again.

I all above does not help, write us with all details to support.coppertino.com