Playback skipping with MP3s

benoit's Avatar

benoit

03 Jul, 2017 10:09 AM

Similar to this issue http://support.coppertino.com/discussions/vox-for-mac/2742-music-skipping , I thought my collection was heavily corrupted. Using various MP3 checkers tools showed no signs of corruption on most files, and playback in itunes is fine.

 I looked at the FAQ relative to this topic http://support.coppertino.com/kb/vox-for-mac/audio-glitches-issue
- Dont have any audio units on, no EQ neither
- "load the whole file into memory" is checked, but probably not the source of the issue, much more bandwidth available than mp3 playback would require. Loads the whole file under a second usually.
- "Sync sample rate option" is off never used it

I also listen to FLAC and WAV files without any trouble.

Here are some more information from questions in the previous ticket
1) Your output device name, or if it's internal one.
Fiio USB DAC-E10
Output is set in "Audio Midi Setup" System panel to 2ch 24b 96.0 kHz, I guess the audio subsystem is performing upsampling from the 16b 44.1kHz from vox playback

2) skipping file format
MP3 with variable bitrate

3) Are Your files local to mac or are they located at external HD?
On an AFP network share; Also tried with SMB share same issue

4) is Your mac connected to power when "skipping" occurs?
Yes

5) Your OS X version
Sierra 10.12.5 (16F73)

6) Your Vox version
2.8.26 Build 2899.26

Mid 2015 15" Mac Book Pro with core i7 2.2GHz and 16G RAM + super fast 256GB M2 SSD

First file provided VBR MP3 (01-presidents_of_the_united_states_of_america-kitty-rec.mp3) :
- I cant reproduce the skips at some specific playback time. It just appears sometimes, mostly when Vox is in background and I'm doing something else.
- Seems there is less skips and glitches when playing from the local disk
Second file Fixed Rate 192KBps mp3 (02-Its_Electric.mp3)
- I was able to reproduce the same glitch every time at 1.42
- Played it back in iTunes, no glitch
- Copied the file locally and played it in Vox, no skip
- Played again the file from the network share, no glitch

I think multiple bugs exists in Vox with network shares
- These gliths mostly inexistants with local files
- Caching issue I already reported here http://support.coppertino.com/discussions/vox-for-mac/5138-file-system-not-updated-when-adding-in-the-add-files-to-playlist-window-selector

Would be great if you have any information on this issue I have a lot of MP3s and I cannot (and dont want to) copy all my collection locally

  1. 1 Posted by benoit on 03 Jul, 2017 11:27 AM

    benoit's Avatar

    I ran into the same issue with this other 320kbps VBR MP3

    Skip occured at 0:20

    Was able to reproduce 3 times by rewinding the song in player. Then stopped play back in vox, played it in iTunes : no skips. Played it again in vox and no skip (All from the same AFP network share)

  2. 2 Posted by benoit on 03 Jul, 2017 01:44 PM

    benoit's Avatar

    Another example with a 256Kbps VBR MP3.

    The file skips multiple time, starting around 0:30 on first play back.
    Stopping player and restart playback (move to another song, the double click on the same song again) made the problem disappear.

    Looks like to me the buffer initially filled is corrupted or the player is unable to play it corrctly starting empty, then play its fine if you restart when its full. Or something like that.

  3. Support Staff 3 Posted by VOX Developers on 04 Jul, 2017 02:21 PM

    VOX Developers's Avatar

    Hello,
    Thank you for your report!
    We will investigate this further. Have you noticed something similar with any other player? Can you still hear skipping with same files located on a local drive? Or only while playing from a network share.

  4. 4 Posted by benoit on 05 Jul, 2017 08:43 AM

    benoit's Avatar

    Good morning,

    Thank you for your answer.

    I've spend some time doing more testing. here's what I found

    - Never appears while playing local files
    - Never happens if "load the whole file into memory" is unchecked
    - Not happen if the file is played once in iTunes, then played in vox
    - Happens when
        - "load the whole file into memory" is checked
        - Playing the track from the network share for the first time, and only first play
            - If you play it again from the same playlist its ok
            - If you empty playlist, close vox then reopen it, does not reproduce for the same track
        - Playing a track never played recently to ensure its not cached in filesystem

    It appears much more frequently with VBR files; but also heard this with CBR encoding
    I can perform further testing if you need some

    I dont think this is related to my file server because I've used multiple sharing protocols (smb, nfs, afp) and I've migrated the complete machine (new cpu/motherboard, new zfs raid array, fresh debian install, etc.) recently and the problem still appears. Also I use the same file server to play on other devices in the house and never eard skips like that

  5. Support Staff 5 Posted by VOX Developers on 05 Jul, 2017 01:59 PM

    VOX Developers's Avatar

    Thank you for your observations. Your assistance helps a lot. Everything above is logged to audio engine developer.

    Stay tuned!

  6. 6 Posted by Cameron on 20 Jul, 2017 07:07 AM

    Cameron's Avatar

    Having the same issue, even with FLACs. ETA on a fix, developers?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 01-presidents_of_the_united_states_of_america-kitty-rec.mp3 4.77 MB
  • 02-Its_Electric.mp3 4.9 MB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac