Sample rate doesn't change when using headphones with built-in external DAC

Cade Gober's Avatar

Cade Gober

18 Feb, 2017 12:47 AM

Hi there, Coppertino. I been using VOX for iOS for a few months now, and just bought a pair of Sony MDR1ADAC Headphones to use along side it. The headphones come with a built-in DAC that supports up to 24-bit 192khz audio, so I figured it would work well with my iPhone 7. However, when I started the music through VOX, I went to check if the sample rate had changed and found that it hadn't. I've tried it with audio ranging from 48 kHz to 192 kHz, but it stays at 44.1 kHz, even with the "Sync Sample Rate" feature switched on. I've included screenshots of the app to show the problem. Let me know if there's a solution. Thanks in advance.

  1. 1 Posted by Cade Gober on 18 Feb, 2017 12:53 AM

    Cade Gober's Avatar

    I forgot to mention. The headphones are connected via a lightning cord that came with them, not the iFixit external headphone jack.

  2. 2 Posted by soundguy on 18 Feb, 2017 01:02 PM

    soundguy's Avatar

    Hi Cade,

    Thank You for getting in touch on this matter.
    That's very interesting as we've never tested Vox on headphones like these.
    But we tested on several hi quality products like Apogee Duet and other, that do switch Sample Rate in Vox just fine.

    The problem may be in fact that we are only able to set "preferred" sample rate in iOS, meaning, device may refuse to change output sample rate even though Your application is asking for this.

    I will try to find similar phones and test this, meanwhile, please check this for us:
    uninstall Vox completely, install it anew. Try files of different SR's several times each (iOS may take time to switch SR).
    Share results with us.

    Thank You beforehand.

  3. 3 Posted by Cade Gober on 19 Feb, 2017 03:15 AM

    Cade Gober's Avatar

    Hello, again.

    So I tried what you told me to do, but the SR still doesn't show a change. I also trying it on my iPad Pro and got the same result. I did, however, notice that when I play the one 192 kHz album I own through the headphones that a distinctive whistle that was previously present in certain songs is now gone. Could it be that the app is actually changing the SR but failing to change the output text? Let me know. Thanks for the quick response!

  4. 4 Posted by soundguy on 20 Feb, 2017 09:59 AM

    soundguy's Avatar

    Theoretically yes - You cannot exclude the possibility that iOS fails to tell Vox the actual current sample rate, but I have not seen occurrences of this so far, in several years of development.

    Try to open/close "Output Sample Rate" in Audio Settings couple of times during playback of the same track - if the reading doesn't change, probably, it's telling the truth. Because it's possible that switching SR on this device takes too much time (seconds), and Vox reading gets updated before actual change takes place. But I doubt this scenario is true.

    Anyway thank You for information and we will keep eye on issue.

  5. 5 Posted by Cade Gober on 26 Feb, 2017 12:51 AM

    Cade Gober's Avatar

    Hey. Sorry I took a few days to respond. So I've discovered that when my headphones are connected, the phone says that the audio is playing through a "Dock Connector" (photo included). Does it say this when a DAC like the apogee duet is connected to connected? Let me know. Also, I've included photos of the cable I use with the headphones, since they aren't like the typical lightning cable. Thanks again.

  6. 6 Posted by soundguy on 26 Feb, 2017 06:32 AM

    soundguy's Avatar

    Is there a way to connect these headphones to a mac and use desktop Vox? Then we can see SR changes more clearly in Audio MIDI Setup app.

  7. 7 Posted by Cade Gober on 27 Feb, 2017 10:25 PM

    Cade Gober's Avatar

    Yes. The headphones come with multiple cables, including a cable for charging and for PC/Mac usage. I've included photos of the cable and the headphones working with VOX on my MacBook Pro, showing that the sample rate does change and is supported on MacOS. Let me know what you think.

  8. 8 Posted by soundguy on 28 Feb, 2017 08:34 PM

    soundguy's Avatar

    looks like it would take some time to reproduce and resolve... I need to have headphones like these first, which I don't have currently, but I have the problem in mind.Please try the next update also to see if changes made now take any effect on this issue...

  9. 9 Posted by Cade Gober on 31 Mar, 2017 06:43 PM

    Cade Gober's Avatar

    *This is my second attempt at posting this. If it appears twice, my apologies.

    Hello again. I'm glad to say that I've found a solution to this bug. After doing some research online, I found a forum that mentioned using an iPhone cable meant for USB Cameras to connect to external DACs ((the full name of the cable is "Lightning to USB Camera Adapter") it's pictured below). I went and tested it out and, to my relief, not only does it recognize the headphones by name under audio devices (pictured below), but it also changes the sample rate in-app as well (pictured below)! Now, given the way I got it working, I believe that this is not a bug with VOX, but with the iOS firmware or the headphones. So it might not be something you can fix. Anyway, thanks for your help, guys. I hope this helps others that are having the same problem.

  10. 10 Posted by soundguy on 31 Mar, 2017 07:35 PM

    soundguy's Avatar

    Cade,

    Thank You for this information. I have yet to study it in-depth but from what I see looks like some kind of hardware of firmware problem. We've been testing Vox with external DACs and found that sometimes Vox fails to switch device to a new SR because device takes too long to switch. Now we know of other scenarios also.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • IMG_0206.PNG 1.77 MB
  • IMG_0205.PNG 342 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac