Accented letters get scrambled. Very Windows v Mac, pre-Unicode

chester's Avatar


16 Oct, 2017 04:31 PM

Hi Voxers. I love your software on both my phone and my Mac, and use it to play high res audio files both places. I really love that I can play super high res FLAC/ALAC files, as well and DSD files, and Vox pushes them quickly to my NAD DAC/Amp.

Only bug I can see, and it's an old problem: Some accented letters sometimes get scrambled. Examples:
è becomes č
Å becomes Ĺ
å becomes ĺ
ø becomes ř
à becomes ŕ
í becomes ķ

Non-accented latin letters are also garbled:
ð becomes š
Æ becomes Ć
æ becomes ć

(Some letters work sometimes, but not others. Some letters seem to come out alright, such as œ.)

As a person who works in typography, it seems that the Uppercase/lowercase are mapping correctly within the context of the wrong codepage, which is what appears to be the issue. How is the software handling fonts and codepages and Unicode?

Hope this helps your troubleshooting,

  1. Support Staff 1 Posted by VOX Developers on 18 Oct, 2017 03:02 PM

    VOX Developers's Avatar

    Hello CJ,
    Thank you for using our app!
    Please specify which platform are you referring to. What is your system language and first preferred language? Have you tried using auto-charset detection feature in VOX for Mac?

  2. 2 Posted by chester on 18 Oct, 2017 03:13 PM

    chester's Avatar

    Thanks for the reply.
    I am on MacOS. 10.12.6.

    I can't find "auto-charset detection". Is that supposed to be in the Prefs?

    Standing by,

  3. Support Staff 3 Posted by VOX Developers on 19 Oct, 2017 10:49 AM

    VOX Developers's Avatar

    Yes, in prefs. Try both, with enabled charset detection and disabled also.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac